SmallStyle


2009-02-11

_ 認証が必要な Proxy 環境で gem を使う

Windows 上で認証が必要な Proxy 環境で gem を利用するときは,以下のおまじないを実行してから利用する.

C:\> set http_proxy=http://<username>:<password>@<hostname>:<port>

_ sqlite3-ruby のインストールが失敗する

何も考えずに,

C:\> gem install sqlite3-ruby

とするとエラーになる.なので古いバージョンの 1.2.3 を利用する.

C:\> gem install sqlite3-ruby -v 1.2.3

_ Redmine と VisualSVN

VisualSVN をいれて Redmine と連携させる.普通にリポジトリを指定すると,エラーになってしまったんだが,Path に VisualSVN の bin を通しておくと参照できるようになった.


最近の日記